コンテンツへスキップ

リモートデスクトップ接続ができなくなった件。
【Raspberry Pi 】

昨日まではできていたのに、今日はリモートデスクトップ接続ができない。

【Raspberry Pi OS】で【xrdp】を使っています。

run.log がディスク容量を使い切っていました。← 削除

再生成された run.log を見てみると、「Checking for updates」と出ていました。

アプリケーションを更新(apt upgrade)したら、なおりました^^。← 結論

xrdp 経由 でリモートデスクトップ接続ができなくなった件。

リモートデスクトップ接続ができない。

急にRDP 接続できなくなる。
ログインはできているけど、接続に問題が出ていると。

図1: リモートデスクトップ接続のログ画面。ログインまでは成功してるのに「connection problem, giving up」と出て接続失敗。
図1: リモートデスクトップ接続のログ画面。ログインまでは成功してるのに「connection problem, giving up」と出て接続失敗。

run.log がディスク容量を使い切っていました

とりあえずssh で、xrdp を再インストールしてみようと思った矢先。
ディスクの空き容量がないとのメッセージが表示される。

図2: SSH経由でxrdpを再インストールしようとしたら「デバイスに空き領域がありません」とエラーが出てインストールできない。
図2: SSH経由でxrdpを再インストールしようとしたら「デバイスに空き領域がありません」とエラーが出てインストールできない。

確かに。

なんか、使い切っとる。

図3: 「df -h」で確認したら、/dev/rootが29G中29G使用の100%表示。ディスクがパンパンだった。
図3: 「df -h」で確認したら、/dev/rootが29G中29G使用の100%表示。ディスクがパンパンだった。

「df -h」で確認。(「-h」オプションをつけると、見やすい単位で表示。)

lxsession が原因らしい。

今度は「du -h」で確認。

図4: 「du -h」で調べてみると、.cacheフォルダだけで24GBも占領してる。
図4: 「du -h」で調べてみると、.cacheフォルダだけで24GBも占領してる。

cache が異常にデカいので、中身を確認してみます。

図5: cacheの中身を「ls -lha」で確認。lxsessionフォルダが怪しい。
図5: cacheの中身を「ls -lha」で確認。lxsessionフォルダが怪しい。
図6: lxsessionの中を「du -h」で見てみると、LXDE-pi以下がまるごと24GB。
図6: lxsessionの中を「du -h」で見てみると、LXDE-pi以下がまるごと24GB。
図7: さらに掘っていくと、run.logが24GBという爆弾サイズになっていた。犯人はこいつ。
図7: さらに掘っていくと、run.logが24GBという爆弾サイズになっていた。犯人はこいつ。

よし。消そう。

その後、xrdp の再インストールをしました。

図8: cacheを削除してxrdpを再インストールした結果、今度は画面が真っ黒になってしまった…orz
図8: cacheを削除してxrdpを再インストールした結果、今度は画面が真っ黒になってしまった…orz

結果、画面が黒に変化するようになりました。orz

多分「got unmount for unknown desktop item」が原因。

後日、run.log を監視しながらRaspberry Pi を触っておりましたら、USB メモリ(Micro SD カードを挿した、USB アダプタです。)を引き抜いたタイミングで

** (pcmanfm:1661): WARNING **: 22:15:52.630: got unmount for unknown desktop item

が無限に書き込みされるのに気が付きました。

図9: run.logを監視してたら「got unmount for unknown desktop item」という警告が無限に流れ続けているのを発見。
図9: run.logを監視してたら「got unmount for unknown desktop item」という警告が無限に流れ続けているのを発見。

root 権限でumount から解除しても上記のログが出ます。

また、USB メモリを挿す時にも、以下の画面とともに、 got unmount for unknown desktop item が出てました。

図10: USBメモリを挿した時にも「Device /dev/sda1 is already mounted」というエラーダイアログが出た。
図10: USBメモリを挿した時にも「Device /dev/sda1 is already mounted」というエラーダイアログが出た。

多分、このUSB メモリがRaspberry Pi と相性が悪い。

run.log の超絶肥大化の原因はこのログ、デバイスと思ってよいと思います。

この USB メモリはRaspberry Pi の電源を落としてから着脱することにします。

「Checking for updates 」

先ほど肥大化していたこともあり、run.log をログを確認してみました。

/home/uniuni/.cache/lxsession/LXDE-pi/run.log

図11: run.logを「tail -f」で見てみると「Checking for updates」というメッセージが出ている。
図11: run.logを「tail -f」で見てみると「Checking for updates」というメッセージが出ている。

今のところ、肥大化しそうな雰囲気はありませんでした。

「** (pcmanfm:2170): CRITICAL **: 22:16:32.541: FmFileInfoJob failed on desktop mount update」
なんかクリティカルが刺さってて焦りましたが、ググっても不明。

他にもいろいろと出ていましたが、特に「Checking for updates 」のメッセージが気になる。

確かにアップデートがあるって言う通知は来ていましたが、
昨日まで問題なく動作していた訳ですし、アップデートしていないのが問題なのでしょうか。

後日追記(2021 11/30)

なんらかのアプデ通知が来たのでrun.log も確認してみたところ、「Checking for updates」が出ていました。
やっぱりただの通知でしたね。

図12: /etc/rc*.d以下をGeanyと端末で確認。xrdpの起動スクリプト(S01xrdp)はちゃんと登録されてる。
図12: /etc/rc*.d以下をGeanyと端末で確認。xrdpの起動スクリプト(S01xrdp)はちゃんと登録されてる。
図13: run.logを改めて確認すると「Checking for updates」「Cache updated - comparing versions」が出てるだけで、ただのアップデート通知だった。
図13: run.logを改めて確認すると「Checking for updates」「Cache updated – comparing versions」が出てるだけで、ただのアップデート通知だった。

アップデートしたら なおった。

悪い事でもないし、アプリケーションの更新をしてみることにしました。

図14: 悪いことでもないし、と「apt upgrade」でアプリケーションを更新中。
図14: 悪いことでもないし、と「apt upgrade」でアプリケーションを更新中。

なおったし^^。

図15: アップデート後、リモートデスクトップ接続の画面もちゃんと表示されるようになって無事解決。
図15: アップデート後、リモートデスクトップ接続の画面もちゃんと表示されるようになって無事解決。

しばらく、run.log を「tail -f」で眺めてましたが、肥大化しそうな雰囲気はありません。

ついでに/var/log/xrdp.log も確認してみたところ、[ERROR] がところどころ出ていることに気付いてしまい、心配になりましたが、とりあえず問題は起きていないので放置することにします。

run.log の「超絶肥大化」は何だったのか。

アップデートを無視していた事が、一連(run.log 超絶肥大化も含めた)の不具合の原因だったのか。

→(2021 11/28 追記)ログ肥大化は下記の警告ログの無限書き込みと思われます。
「** (pcmanfm:1661): WARNING **: 22:15:52.630: got unmount for unknown desktop item」
SD カードリーダーのUSB デバイスを抜き差しすると発生していることに気が付きました。
なので、ログ肥大化自体は今回のRDP 接続不良には関係ありませんが、肥大化した結果、何らかの問題を引き起こした可能性はあると思われ。

そして、アップデートした事で問題が解消されたのか。

正直、何一つわからない。。。orz

(2022 2/13 追記)現象が再現したので、肥大化したrunlog を削除したのち、一度再起動したところで治りました。Linux ではハードディスクがいっぱいになってシステム用の領域でしか起動できてなかったことが原因だと考えています。

という訳で、以上です。

(Visited 1,677 times, 1 visits today)

コメントを残す

メールアドレスが公開されることはありません。 が付いている欄は必須項目です